Problems with hyper-threading on Asus P4T533 / Linux 2.4.20

From: Lars Magne Ingebrigtsen (
Date: Wed Feb 12 2003 - 09:03:59 EST

We've just gotten an Asus P4T533-based machine with a 3.06GHz P4 CPU,
bios version 1005. (P4T533 is i850e-based.) The bios claims that the
P4 has hyper-threading, and as you can see from the cpuinfo output
below, "ht" is among the flags. (And the manual says that P4T533 is

I've tried booting with acpismp=force and without, and it doesn't
seem to make much difference: Linux still only sees a single CPU.
I've also tried 2.4.21-pre4 and -ac4, which doesn't seem to make any
difference, either.

Anybody got any ideas why I can't get this to work?

buto:~# uname -a
Linux buto 2.4.20 #3 SMP Wed Feb 12 14:28:49 CET 2003 i686 unknown
buto:~# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Intel(R) Pentium(R) 4 CPU 3.06GHz
stepping : 7
cpu MHz : 3073.691
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips : 6134.16

(domestic pets only, the antidote for overdose, milk.) * Lars Magne Ingebrigtsen

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to More majordomo info at Please read the FAQ at

This archive was generated by hypermail 2b29 : Sat Feb 15 2003 - 22:00:41 EST