Re: [PATCH] allow gpiolib to be a module

From: Linus Walleij
Date: Wed Sep 12 2012 - 11:53:20 EST

On Wed, Sep 12, 2012 at 9:43 AM, Jan Beulich <JBeulich@xxxxxxxx> wrote:

>> I can't parse this, sorry the gpio subsystem maintainer is too bad coder.
>> What about something more readable?
>> int ret;
>> ret = gpiolib_sysfs_init();
>> if (ret)
>> return ret;
>> return gpiolib_debugfs_init();
>> I know it doesn't look as cool but it's easier for me to understand.
> Okay, since you're the second one to complain despite there
> being other uses of the construct in the same source file, I'll
> replace it, ...

Sorry about that, but two wrongs does not make one right.
I'd be happy if you patch the other constructs too...

Linus Walleij
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at