Re: [PATCH] allow gpiolib to be a module
From: Jan Beulich
Date: Wed Sep 12 2012 - 03:43:04 EST
>>> On 11.09.12 at 19:38, Linus Walleij <linus.walleij@xxxxxxxxxx> wrote:
> On Mon, Sep 10, 2012 at 2:16 PM, Jan Beulich <JBeulich@xxxxxxxx> wrote:
>> +#ifndef MODULE
>> #endif /* DEBUG_FS */
>> +#ifdef MODULE
>> +int __init gpiolib_init(void)
>> + return gpiolib_sysfs_init() ?: gpiolib_debugfs_init();
> I can't parse this, sorry the gpio subsystem maintainer is too bad coder.
> What about something more readable?
> int ret;
> ret = gpiolib_sysfs_init();
> if (ret)
> return ret;
> return gpiolib_debugfs_init();
> I know it doesn't look as cool but it's easier for me to understand.
Okay, since you're the second one to complain despite there
being other uses of the construct in the same source file, I'll
replace it, ...
> There is a bug too: I don't think this compiles if you compile as
> a module but disable debugfs. Try it out.
... the more to get this one fixed. Will re-submit.
>> +MODULE_DESCRIPTION("GPIO library");
> These two things don't really need to be inside an #ifdef
They don't need to be, but since we need a conditional now
anyway, it seemed reasonable to include these in there too.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/