Re: Question about error from xhci-hcd

From: Sarah Sharp
Date: Tue Feb 07 2012 - 09:59:40 EST

On Tue, Feb 07, 2012 at 07:30:02AM -0600, Larry Finger wrote:
> On 02/06/2012 11:47 PM, Richard Farina wrote:
> >I apologize but I am having the same issue reported in this thread in
> >December
> >
> >[ 5077.573181] xhci_hcd 0000:0a:00.0: ERROR no room on ep ring
> >
> >I saw no resolution on this issue so I figured I'd step up and see if
> >you needed an active tester who could reproduce the issue.
> >
> >I am running Gentoo with a 3.2.2 kernel. I am able to run any kernel
> >version you need, including random git trees and custom patches. If you
> >have not solved this yet, please allow me to be your test monkey. If you
> >have solved this already then sorry for harming the signal to noise
> >ratio, I could not a find a later message then the one below.
> Are the "no room" messages triggered by rtl8192cu, or some other driver?

They can be caused by any USB driver that attempts to queue large
transfers or many small transfers.

Sarah Sharp
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at