Re: What's up with wireless drivers?

From: Piotr Hosowicz
Date: Sat May 22 2010 - 09:41:06 EST

On 22.05.2010 15:35, Justin P. Mattock wrote:
On 05/22/2010 06:13 AM, Piotr Hosowicz wrote:
On 22.05.2010 14:43, Piotr Hosowicz wrote:
On 22.05.2010 10:40, Piotr Hosowicz wrote:
On 22.05.2010 00:20, Piotr Hosowicz wrote:
On 22.05.2010 00:12, Randy Dunlap wrote:
On Fri, 21 May 2010 23:31:28 +0200 Piotr Hosowicz wrote:

On 21.05.2010 23:21, Piotr Hosowicz wrote:
On 21.05.2010 23:07, John W. Linville wrote:
On Fri, May 21, 2010 at 10:53:56PM +0200, Piotr Hosowicz wrote:

I try to build kernel from git source. Now n-th build try is
performing, each time it failed on wireless drivers - Atheros,
Marvel etc. Did I miss something?


Piotr Hosowicz

Perhaps you should post your actual output from the build failure?

I dont have it right now, I disabled wireless at all and started
The output to the console was make-kpkg ordinary message - saying
sub build finished with error code 2 AFAIR, it stopped each time on
wireless drivers.

Zonk! It seems that the problem is not only with wireless, now it

CC [M] drivers/net/usb/int51x1.o
CC [M] drivers/net/usb/cdc-phonet.o
CC [M] drivers/net/wan/lmc/lmc_media.o
CC [M] drivers/net/wan/lmc/lmc_main.o
CC [M] drivers/net/wan/wanxl.o
CC [M] drivers/net/usb/ipheth.o
LD [M] drivers/net/wan/cyclomx.o
CC [M] drivers/net/usb/sierra_net.o
CC [M] drivers/net/wan/lmc/lmc_proto.o
LD [M] drivers/net/wan/lmc/lmc.o
make[1]: Opuszczenie katalogu
make: *** [debian/stamp/build/kernel] Błąd 2

Opuszczenie katalogu `/usr/src/linus/linux-2.6-20100521-2044' is
"leaving directory", Błąd is error.

That still doesn't show the actual error/problem message...

Because there was no other messages, maybe Debian make-kpkg mutes them
some way. I can try tommorrow the classic linux way and test it. I
attach botching config.

I git-pulled and have run build with make-kpkg --verbose, again failed.
This is the tail of the output:


I tried git8 from and the make-kpkg build fails on iwlwifi.
I'll give up for today I think.

I gave it one more try and it failed again like in my first post

CC [M] drivers/net/wireless/rtl818x/rtl8187_rtl8225.o
CC [M] drivers/net/wireless/zd1211rw/zd_usb.o
CC [M] drivers/net/wireless/rtl818x/rtl8187_leds.o
CC [M] drivers/net/wireless/rtl818x/rtl8187_rfkill.o
LD [M] drivers/net/wireless/rtl818x/rtl8180.o
LD [M] drivers/net/wireless/rtl818x/rtl8187.o
LD [M] drivers/net/wireless/ath/ath9k/ath9k_hw.o
LD [M] drivers/net/wireless/ath/ath9k/ath9k_common.o
LD [M] drivers/net/wireless/ath/ath9k/ath9k_htc.o
LD [M] drivers/net/wireless/ath/ath.o
LD [M] drivers/net/wireless/zd1211rw/zd1211rw.o
make[1]: Opuszczenie katalogu `/usr/src/linux-2.6.34-git8'
make: *** [debian/stamp/build/kernel] Błąd 2

zd1211rw is in wireless Zydas device driver, behaves like yesterday

I am giving up for a time being or may be someone will help me here.


Piotr Hosowicz

not sure whats happening and/or how debian is
building the kernel, but can you try
make V=1 so there is more of a verbose message
on the screen of whats breaking.

This is the same what --verbose make-kpkg switch is doing and I've tried that and posted result here.


Piotr Hosowicz

<Nub> Może mi ktoś wytłumaczyć, jak dzielą sie komórki?
<Tolek> o
<Tolek> O
<Tolek> 8
<Tolek> o o
NP: Black Stone Cherry - Lonely Train
NB: 2.6.34-20100521-1728
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at