Re: [bisected] 2.6.29-rc1 Firefox crashing on page load

From: Justin Madru
Date: Tue Jan 20 2009 - 21:39:28 EST

Hiroshi Shimamoto wrote:
Justin Madru wrote:
Hiroshi Shimamoto wrote:
Justin Madru wrote:
Hiroshi Shimamoto wrote:
Justin Madru wrote:
Ok, finally bisected the bug, but the commit isn't related to networking!
I did: git revert 4217458dafaa57d8e26a46f5d05ab8c53cf64191
on current git and that fixed the bug.

By the way, how do I undo my git revert, so I'm back to a pristine tree?
I want to drop my changes - the revert.
Also how do I find the commit that merged/pulled in this commit?

commit 4217458dafaa57d8e26a46f5d05ab8c53cf64191
Author: Hiroshi Shimamoto <h-shimamoto@xxxxxxxxxxxxx>
Date: Fri Dec 5 17:17:09 2008 -0800

x86: signal: change type of paramter for sys_rt_sigreturn()

Impact: cleanup on 32-bit

Peter pointed this parameter can be changed.

Signed-off-by: Hiroshi Shimamoto <h-shimamoto@xxxxxxxxxxxxx>
Signed-off-by: Ingo Molnar <mingo@xxxxxxx>
thanks for reporting.

I'm not sure why this commit affects.
Can you check vmlinux? size, objdump, etc.
On my environment, the generated code looks same.


I tried to do an objdump but it gave an error. How am I suppose to do an objdump?

$ objdump -x /boot/vmlinuz-2.6.29-rc2-git
objdump: /boot/vmlinuz-2.6.29-rc2-git: File format not recognized
$ readelf -a /boot/vmlinuz-2.6.29-rc2-git
readelf: Error: Unable to seek to 0xc031f2eb for section headers
readelf: Error: Not an ELF file - it has the wrong magic bytes at the start
$ ls -la /boot/vmlinuz-2.6.29-rc2-git
-rw-r--r-- 1 root root 2286480 2009-01-19 18:44 /boot/vmlinuz-2.6.29-rc2-git
not vmlinuz, vmlinux.
vmlinuz is a compressed kernel, it is not ELF file.
Usually vmlinux is generated in top of source directory.
I can see disassembled image with objdump -d vmlinux.


Sorry, didn't know. I tried objdump -d vmlinux, but the resulting file is ~50MB!
Is there a smaller section you're interested in, because that would be hard to send.
Or am I doing it wrong again?

that's OK. No need to send the disassembled result.
You can diff disassembled file.
I guess your GCC generates different code when the patch is reverted.


Ok, I tried, I really did. But no mater what I did the diff was even bigger
if not the same size as the original dump! I even tried to cut out the first two fields with
cut -f3- dump-revert > dump-revert2
but that wouldn't shrink the diff size (100,000+ lines).

Does gcc output fluctuate this wildly with such little change?
Is there a config option that allows gcc to randomize the output?
I recompiled just to make sure, and even two recompiles of the same source (no revert)
resulted in a different sha1 hash (didn't test the objdump diff).
The only thing I can think of is that I compile with -O3 instead of -O2.

I'm sorry, but unless you have any suggestions I've decided to just upload
the vmlinux files to my server (<40KB up speed)
and rapidshare

By the way Ingo has already added the revert to tip/master;a=commit;h=1d03950243904c89b8854c10516932b029c2a8fa

Justin Madru
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at