Re: [bisected] 2.6.29-rc1 Firefox crashing on page load

From: Hiroshi Shimamoto
Date: Tue Jan 20 2009 - 14:49:17 EST

Justin Madru wrote:
> Hiroshi Shimamoto wrote:
>> Justin Madru wrote:
>>> Hiroshi Shimamoto wrote:
>>>> Justin Madru wrote:
>>>>> Ok, finally bisected the bug, but the commit isn't related to networking!
>>>>> I did: git revert 4217458dafaa57d8e26a46f5d05ab8c53cf64191
>>>>> on current git and that fixed the bug.
>>>>> By the way, how do I undo my git revert, so I'm back to a pristine tree?
>>>>> I want to drop my changes - the revert.
>>>>> Also how do I find the commit that merged/pulled in this commit?
>>>>> commit 4217458dafaa57d8e26a46f5d05ab8c53cf64191
>>>>> Author: Hiroshi Shimamoto <h-shimamoto@xxxxxxxxxxxxx>
>>>>> Date: Fri Dec 5 17:17:09 2008 -0800
>>>>> x86: signal: change type of paramter for sys_rt_sigreturn()
>>>>> Impact: cleanup on 32-bit
>>>>> Peter pointed this parameter can be changed.
>>>>> Signed-off-by: Hiroshi Shimamoto <h-shimamoto@xxxxxxxxxxxxx>
>>>>> Signed-off-by: Ingo Molnar <mingo@xxxxxxx>
>>>> Hi,
>>>> thanks for reporting.
>>>> I'm not sure why this commit affects.
>>>> Can you check vmlinux? size, objdump, etc.
>>>> On my environment, the generated code looks same.
>>>> Thanks,
>>>> Hiroshi
>>> I tried to do an objdump but it gave an error. How am I suppose to do an
>>> objdump?
>>> $ objdump -x /boot/vmlinuz-2.6.29-rc2-git
>>> objdump: /boot/vmlinuz-2.6.29-rc2-git: File format not recognized
>>> $ readelf -a /boot/vmlinuz-2.6.29-rc2-git
>>> readelf: Error: Unable to seek to 0xc031f2eb for section headers
>>> readelf: Error: Not an ELF file - it has the wrong magic bytes at the start
>>> $ ls -la /boot/vmlinuz-2.6.29-rc2-git
>>> -rw-r--r-- 1 root root 2286480 2009-01-19 18:44 /boot/vmlinuz-2.6.29-rc2-git
>> not vmlinuz, vmlinux.
>> vmlinuz is a compressed kernel, it is not ELF file.
>> Usually vmlinux is generated in top of source directory.
>> I can see disassembled image with objdump -d vmlinux.
>> Thanks,
>> Hiroshi
> Sorry, didn't know. I tried objdump -d vmlinux, but the resulting file
> is ~50MB!
> Is there a smaller section you're interested in, because that would be
> hard to send.
> Or am I doing it wrong again?

that's OK. No need to send the disassembled result.
You can diff disassembled file.
I guess your GCC generates different code when the patch is reverted.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at