Re: [PATCH 03/17] x86-64: Convert irqstacks to per-cpu

From: Ingo Molnar
Date: Sun Jan 18 2009 - 03:36:59 EST

* Tejun Heo <tj@xxxxxxxxxx> wrote:

> Hello,
> Brian Gerst wrote:
> >> Also, as pda field name, irqstackptr might be fine but wouldn't it be
> >> better to rename it to at least irq_stack_ptr as this change requires
> >> touching every users anyway?
> >
> > I kept the same name unless it would conflict with something. If you
> > want to rename it, it should be a separate patch.
> Sure, that's an option too but it might as well be done when making
> those percpu variables. I don't really see why those two changes should
> be separate. There isn't any reason why they shouldn't be separate
> either but if you're already mucking around every user...

yes, we should do the rename in this same patch as both patches have no
impact on the actual kernel image. (sans source code line and string
related deltas in the image.) Feel free to do the rename in his patch -
that's the fastest way.

I'd suggest to rename from:

DECLARE_PER_CPU(char *, irqstackptr);


DECLARE_PER_CPU(char *, irq_stack_ptr);

In other cases, lets get Brian's patches in without further latencies so
that we drain his pending-patches pipeline and get a consolidated base
everyone can work from. Brian already had an unfortunate (and
time-consuming) rebase/conflict-resolution pass due to us moving the
percpu code from under him. We can do non-critical followups in separate
delta patches.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at