Re: [Patch] 1/5 in support of hot-add memory x86_64 nodes_addcleanup

From: keith mannthey
Date: Sat Jul 29 2006 - 15:20:38 EST

On Sat, 2006-07-29 at 18:24 +0200, Andi Kleen wrote:
> If you add attachments (which are harder to review because they cannot be
> quoted) put at least a copy of the description into the attachment and make
> them inline.

Sorry I will do this if the future.
> One thing that's unclear to me is why you make the reserve hotadd Kconfig
> user visible (and why put it into Kconfig at all). I don't think it should be
> user visible.

It was suggested to me in an earlier patch set to move RESERVE_HOTADD to
Kconfig. I can make it a non-user option. It seems that MEMORY_HOTPLUG
is a user options so I figured why not make RESERVE one as well. Also I
don't think people should use reserve with sparsmem.

> Also most of the patch seems to be renaming a variable which seems somewhat
> pointless?

srat.c as it stands is very reserve specific (understandably).
Changing found_add_area to reserve_add_area is extra change help the var
names be more clear with the sharing of the code path as to what is
happening. reserve_add_area is used as a switch for the reserve path.
Since the logic of the code was changing I thought it would be a good
time to change the name to help the clarity of the code.

If you see this as a waste/unneeded I will revert the name change.

Thanks for the comments,

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at