Re: New Radeonfb (2.6.5) driver does not play nice with X (4.3.0)

From: Timothy Miller
Date: Thu Apr 22 2004 - 14:12:00 EST

James Lamanna wrote:
Timothy Miller wrote:
> Are you using ATI's proprietary drivers? I have also experienced this
> sort of system hang when using their drivers. When I would exit the X
> server, I would get a screen full of vertical lines and the system
> would be completely dead (could not ping).

> The short-term solutions are either to use the XFree's native drivers
> or to use vesafb for the console. The long term solution is for ATI to
> fix their drivers.

Well I did try with Driver "vga" (I had been using the ATI proprietary
ones), and it still exhibited the same behavior.

Someone told me that they found the ATI driver to get along fine with the VESA framebuffer driver, but I never tried it. Since I have a 9000, enough of its features are supported by Mesa that I don't care, so I switched back.

Also, I have used ATI's drivers with Red Hat 9, and since Red Hat always just uses the VGA text console, it was never a problem.

Have you tried the plain 80x25 CGA/EGA/VGA character mode with the ATI drivers? Don't use a graphical console driver at all and see what happens.

ATI won't help you if you contact them, but there may be some value in you contacting them with a report of the problem. I did that. If they get enough complaints, maybe they'll deal with it.

I suspect there is a conflict between X and radeonfb both trying to access the drawing engine at the same time.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at