[PATCH] fix for idiocy in mount_root cleanups.

From: Alexander Viro (viro@math.psu.edu)
Date: Sat Dec 08 2001 - 06:40:49 EST


        Grr... OK, that should be a lesson - never do obvious change
just before sending a patch.

        Change in question was s/do_mount/mount/. Which is almost
the same thing, except for one little detail: mount(2) in case of
error returns -1 and stores the error in errno. do_mount(9), OTOH...

IOW, please apply the following and pass me a brown paperbag ;-/

--- C1-pre7/init/do_mounts.c Fri Dec 7 20:48:43 2001
+++ linux/init/do_mounts.c Sat Dec 8 06:29:20 2001
@@ -351,8 +351,9 @@
                 mount("devfs", ".", "devfs", 0, NULL);
 retry:
         for (p = fs_names; *p; p += strlen(p)+1) {
- err = mount(name,"/root",p,root_mountflags,root_mount_data);
- switch (err) {
+ errno = 0;
+ mount(name,"/root",p,root_mountflags,root_mount_data);
+ switch (-errno) {
                         case 0:
                                 goto done;
                         case -EACCES:

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/



This archive was generated by hypermail 2b29 : Sat Dec 15 2001 - 21:00:12 EST