trouble with 2.4.2 just released

From: Heitzso (
Date: Thu Feb 22 2001 - 13:55:28 EST

I have two boxes that I immediately
tried upgrading the OS on. In both
cases I use a script to automate the
build with a saved off .config file.
simplified ..
 untar linux tar ball
 cp config.blat linux/.config
 cd linux
 make oldconfig
 make menuconfig
 cp .config ../config.blat
 make bzImage
 make modules
 make modules_install
 ... copy files around ...

On one box the build completed but
with half a dozen C warnings and
a block of assembler warnings (RH7).
These will always leave a sys admin
nervous about running a kernel.

On the other box I have yet to get a
successful build (using a .config that
runs 2.4.2-pre4 fine). ld complains
about a missing binary file.

ld: cannot open binary: no such file or directory

email be directly at if
someone has a specific question re how
the kernel broke or if they want a copy
of my .config file

Note I'm running debian unstable/woody
on the system that's failing to build
2.4.2, but this same system handled
2.4.2-pre4 albeit with the warnings fine.

Also, feel free to throw the standard
idiot questions at me, I may have made
an idiot mistake. My /usr partition
that has /usr/src/linux tree has 4G
avail, so I'm not running out of drive
space. I'm running the script as root.
I tried both bz2 and gz versions of tarball.
... what am I missing ... ?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Fri Feb 23 2001 - 21:00:28 EST