Re: strange RST packets sent by Linux

Hans-Joachim Zimmer (
Sat, 13 Dec 1997 15:10:15 +0100 (CET)


if you are using JetDirect's built-in LPD (I have tried it on a 4SiMX and
on a 4M) you WILL have problems, at least if the printer is heavily used
by many people. For example it is not possible to do a lpq (watch the
print queue) or lprm (remove jobs) when other jobs are running. This be-
haviour of the JetDirect card has been reported in many newsgroups and
I had very much trouble with it. I think it's the same problem that you
describe as hanging processes and "still opened connections".
The tcp-lp program (part of plp-4.0.3) solves these problems. It talks to
the printer as a pseudo-local one (as if it were connected to a parallel
port). All spooling activity and job management is done on the Linux server.
It really works great for the 4SiMX and the 4M.
For the 5SiMX it is much more involved. I am getting the problems that
I described in the newsgroup. There are often network errors that result
in missing pages when printing. I dont know whose bug it is: the kernels,
the tcp-lp programs or the JetDirects implementation of TCP. I have, how-
ever been able to patch the linux kernel to make the printing errors
disappear. But I still do not know if this patch causes problems for
other applications. The TCP experts are working on the problem.

By the way: The Hewlett-Packard Hotline tried to help me to solve the
problem though I am not using Windows or any other commercial operating

Many thanks to HP


's isch kuul, Maenn!!!

Hansi-Joachim Zimmer
E-Mail :


On Sat, 13 Dec 1997, David Woodhouse wrote:

> We have a problem printing from Linux (stock RH 5.0) to an HP Laserjet 4, with
> the JetDirect adapter. I haven't had time to investigate properly,
> unfortunately.
> What happens is this: the process sending data to the printer aborts (or hangs,
> I haven't even established which, I'm afraid), and the printer refuses all
> attempts to reopen a connection, as if it thinks the old connection is still
> open. This only happens once every few days, and by the time I get there
> someone's usually restarted it.
> I never had any problems printing using lpd, but only since I've started using
> PPR to print using the "tcpip" interface (send data direct to port 9100 of the
> printer)
> Admittedly, I only ever used lpd myself, and it's now using PPR for the whole
> College, so it's possible that I had just never noticed the problem before.
> --
> ---- ---- ----
> David Woodhouse, Robinson College, CB3 9AN, England. (+44) 0976 658355
> finger for PGP key.