Re: [PATCH] mm/thp: Rename TRANSPARENT_HUGEPAGE_NEVER_DAX to _UNSUPPORTED

From: Peter Xu
Date: Thu Mar 16 2023 - 11:19:23 EST


On Thu, Mar 16, 2023 at 03:57:12PM +0100, David Hildenbrand wrote:
> On 15.03.23 18:16, Peter Xu wrote:
> > TRANSPARENT_HUGEPAGE_NEVER_DAX has nothing to do with DAX. It's set when
> > has_transparent_hugepage() returns false, checked in hugepage_vma_check()
> > and will disable THP completely if false. Rename it to reflect its real
> > purpose.
> >
> > Cc: Aneesh Kumar K.V <aneesh.kumar@xxxxxxxxxxxxx>
> > Cc: Yang Shi <shy828301@xxxxxxxxx>
> > Signed-off-by: Peter Xu <peterx@xxxxxxxxxx>
> > ---
> > include/linux/huge_mm.h | 2 +-
> > mm/huge_memory.c | 4 ++--
> > 2 files changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/include/linux/huge_mm.h b/include/linux/huge_mm.h
> > index 70bd867eba94..9a3a3af2dd80 100644
> > --- a/include/linux/huge_mm.h
> > +++ b/include/linux/huge_mm.h
> > @@ -79,7 +79,7 @@ static inline vm_fault_t vmf_insert_pfn_pud(struct vm_fault *vmf, pfn_t pfn,
> > }
> > enum transparent_hugepage_flag {
> > - TRANSPARENT_HUGEPAGE_NEVER_DAX,
> > + TRANSPARENT_HUGEPAGE_UNSUPPORTED,
> > TRANSPARENT_HUGEPAGE_FLAG,
> > TRANSPARENT_HUGEPAGE_REQ_MADV_FLAG,
> > TRANSPARENT_HUGEPAGE_DEFRAG_DIRECT_FLAG,
> > diff --git a/mm/huge_memory.c b/mm/huge_memory.c
> > index b0ab247939e0..913e7dc32869 100644
> > --- a/mm/huge_memory.c
> > +++ b/mm/huge_memory.c
> > @@ -88,7 +88,7 @@ bool hugepage_vma_check(struct vm_area_struct *vma, unsigned long vm_flags,
> > /*
> > * If the hardware/firmware marked hugepage support disabled.
> > */
> > - if (transparent_hugepage_flags & (1 << TRANSPARENT_HUGEPAGE_NEVER_DAX))
> > + if (transparent_hugepage_flags & (1 << TRANSPARENT_HUGEPAGE_UNSUPPORTED))
> > return false;
> > /* khugepaged doesn't collapse DAX vma, but page fault is fine. */
> > @@ -464,7 +464,7 @@ static int __init hugepage_init(void)
> > * Hardware doesn't support hugepages, hence disable
> > * DAX PMD support.
>
>
> We should also fixup that comment then, no?

Yes, I'd drop the comment since the code explains itself. One fixup
attached. Thanks.

--
Peter Xu