Re: [PATCH net-next v3 01/10] net: wwan: tmi: Add PCIe core

From: Yanchao Yang (杨彦超)
Date: Mon Feb 27 2023 - 07:12:07 EST


On Fri, 2023-02-24 at 11:50 -0800, Jakub Kicinski wrote:
> On Fri, 24 Feb 2023 07:39:33 +0000 Yanchao Yang (杨彦超) wrote:
> > > > Do you really need these flags?
> > >
> > > We will check and update if it's really redundant soon.
> >
> > Update test result.
> > Both flags are deleted, then run the make command with
> > "build in" and "build module" on a separate kernel tree. Both
> > suffer
> > the same build error.
> > “drivers/net/wan/mediatek/pcie/mtk_pci.c:16:10: fatal error:
> > mtk_fsm.h:
> > No such file or directory
> > #include "mtk_fsm.h""
> > The reason is that all files are not placed in the same folder. The
> > driver named TMI needs a child folder, then needs these flags.
> >
> > Any ideas or comments for this? Please help share it at your
> > convenience.
>
> Relative paths work, right?
>
Okay. Change as follows, is that right?
mtk_pci.h includes "mtk_dev.h",
which is located in the parent folder.
#include "../mtk_dev.h"

mtk_fsm.c
includes "mtk_reg.h", which is located in the child folder "pcie"
#inclu
de "pcie/mtk_reg.h"

> > > > Labels should be named after action they perform, not where
> > > > they
> > > > jump
> > > > from. Please fix this everywhere.
> > >
> > > We can found similar samples in kernel codes, naming the label
> > > per
> > > where jump from…
> > > ex. pci-sysfs.c
> > > shall we apply this rule to our driver?
> > > I
> > > t's mandatory or nice to have.
> >
> > Any ideas or comments for this? Please help share it at your
> > convenience.
>
> It's mandatory for new code.
Okay. Change as follows, is that right?
......
Ret =
mtk_ctrl_init(mdev);
If (ret)
goto free_fsm;
ret = mtk_data_init(mdev)

If (ret)
goto free_ctrl_plane;
return 0;
free_ctrl_plane:

mtk_ctrl_exit(mdev);
free_fsm:
mtk_fsm_exit(mdev);
exit:
return ret;
}

many thanks.