[PATCH 00/11] staging: rtl8192e: Remove entries from struct rtl819x_ops start with .get_eeprom_size

From: Philipp Hortmann
Date: Sun Feb 19 2023 - 16:15:56 EST


Remove unnecessary entries from rtl819x_ops and replace them with with
function names. This increases readability of the code as the reader does
not always need to look up the corresponding function name.

Tested with rtl8192e
Transferred this patch over wlan connection of rtl8192e

Philipp Hortmann (11):
staging: rtl8192e: Remove entry .get_eeprom_size from struct
rtl819x_ops
staging: rtl8192e: Remove entry .init_adapter_.. from struct
rtl819x_ops
staging: rtl8192e: Remove entry .initialize_ad.. from struct
rtl819x_ops
staging: rtl8192e: Remove entry .tx_fill_descr.. from struct
rtl819x_ops
staging: rtl8192e: Remove entry .tx_fill_cmd_d.. from struct
rtl819x_ops
staging: rtl8192e: Remove entry .rx_query_stat.. from struct
rtl819x_ops
staging: rtl8192e: Remove entry .stop_adapter from struct rtl819x_ops
staging: rtl8192e: Remove entry .update_ratr_t.. from struct
rtl819x_ops
staging: rtl8192e: Remove entry .irq_enable from struct rtl819x_ops
staging: rtl8192e: Remove entry .irq_disable from struct rtl819x_ops
staging: rtl8192e: Remove entry .rx_enable from struct rtl819x_ops

.../staging/rtl8192e/rtl8192e/r8192E_dev.c | 2 +-
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 42 +++++++------------
drivers/staging/rtl8192e/rtl8192e/rtl_core.h | 20 ---------
3 files changed, 15 insertions(+), 49 deletions(-)

--
2.39.2