[PATCH 02/11] staging: rtl8192e: Remove entry .init_adapter_.. from struct rtl819x_ops

From: Philipp Hortmann
Date: Sun Feb 19 2023 - 16:15:53 EST


Remove entry .init_adapter_variable and replace it with function name
rtl92e_init_variables. This increases readability of the code.

Signed-off-by: Philipp Hortmann <philipp.g.hortmann@xxxxxxxxx>
---
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 3 +--
drivers/staging/rtl8192e/rtl8192e/rtl_core.h | 1 -
2 files changed, 1 insertion(+), 3 deletions(-)

diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
index 73f3d0973a5a..7b8683a9bdb1 100644
--- a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
+++ b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
@@ -27,7 +27,6 @@ static char *ifname = "wlan%d";

static const struct rtl819x_ops rtl819xp_ops = {
.nic_type = NIC_8192E,
- .init_adapter_variable = rtl92e_init_variables,
.initialize_adapter = rtl92e_start_adapter,
.link_change = rtl92e_link_change,
.tx_fill_descriptor = rtl92e_fill_tx_desc,
@@ -974,7 +973,7 @@ static short _rtl92e_init(struct net_device *dev)
_rtl92e_init_priv_lock(priv);
_rtl92e_init_priv_task(dev);
rtl92e_get_eeprom_size(dev);
- priv->ops->init_adapter_variable(dev);
+ rtl92e_init_variables(dev);
_rtl92e_get_channel_map(dev);

rtl92e_dm_init(dev);
diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_core.h b/drivers/staging/rtl8192e/rtl8192e/rtl_core.h
index 00e413a644d2..541b7aa366a5 100644
--- a/drivers/staging/rtl8192e/rtl8192e/rtl_core.h
+++ b/drivers/staging/rtl8192e/rtl8192e/rtl_core.h
@@ -205,7 +205,6 @@ struct rtl8192_tx_ring {

struct rtl819x_ops {
enum nic_t nic_type;
- void (*init_adapter_variable)(struct net_device *dev);
void (*init_before_adapter_start)(struct net_device *dev);
bool (*initialize_adapter)(struct net_device *dev);
void (*link_change)(struct net_device *dev);
--
2.39.2