Re: [PATCH] ANDROID: binder: rename parameter to resolve name collision.

From: kuangrufan
Date: Wed May 30 2018 - 23:15:26 EST


> Why is this needed? These don't collide in the namespace:
Sorry, I check it again, you’re right. my bad.

PS:
I need to change the binder API between 32bit & 64bit dynamically.
So I was trying to compile binder as a “.ko”. I compiled the 2
files into the same kernel module, which causes problem.

Best Regards,

> 在 2018年5月30日,下午11:54,Todd Kjos <tkjos@xxxxxxxxxx> 写道:
>
> Why is this needed? These don't collide in the namespace:
>
> /sys/module/binder/parameters/debug_mask
>
> and
>
> /sys/module/binder_alloc/parameters/debug_mask.
>
> On Tue, May 29, 2018 at 9:58 PM <kuangrufan@xxxxxxxxx> wrote:
> From: Kuang Rufan <kuangrufan@xxxxxxxxx>
>
> both bind.c & binder_alloc.c define the same kernel parameter 'debug_mask',
> rename the one in binder_alloc.c to 'alloc_debug_mask'.
>
> Signed-off-by: Kuang Rufan <kuangrufan@xxxxxxxxx>
> ---
> drivers/android/binder_alloc.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/android/binder_alloc.c b/drivers/android/binder_alloc.c
> index 5a426c877dfb..3850dab493d4 100644
> --- a/drivers/android/binder_alloc.c
> +++ b/drivers/android/binder_alloc.c
> @@ -42,7 +42,7 @@ enum {
> };
> static uint32_t binder_alloc_debug_mask;
>
> -module_param_named(debug_mask, binder_alloc_debug_mask,
> +module_param_named(alloc_debug_mask, binder_alloc_debug_mask,
> uint, 0644);
>
> #define binder_alloc_debug(mask, x...) \
> --
> 2.15.1 (Apple Git-101)
>