[PATCH] ANDROID: binder: rename parameter to resolve name collision.

From: kuangrufan
Date: Wed May 30 2018 - 01:06:34 EST


From: Kuang Rufan <kuangrufan@xxxxxxxxx>

both bind.c & binder_alloc.c define the same kernel parameter 'debug_mask',
rename the one in binder_alloc.c to 'alloc_debug_mask'.

Signed-off-by: Kuang Rufan <kuangrufan@xxxxxxxxx>
---
drivers/android/binder_alloc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/android/binder_alloc.c b/drivers/android/binder_alloc.c
index 5a426c877dfb..3850dab493d4 100644
--- a/drivers/android/binder_alloc.c
+++ b/drivers/android/binder_alloc.c
@@ -42,7 +42,7 @@ enum {
};
static uint32_t binder_alloc_debug_mask;

-module_param_named(debug_mask, binder_alloc_debug_mask,
+module_param_named(alloc_debug_mask, binder_alloc_debug_mask,
uint, 0644);

#define binder_alloc_debug(mask, x...) \
--
2.15.1 (Apple Git-101)