Re: [PATCH 5/7] mmc: usdhi6rol0: use to_delayed_work

From: Ulf Hansson
Date: Wed Jan 27 2016 - 09:15:25 EST


On 1 January 2016 at 15:59, Geliang Tang <geliangtang@xxxxxxx> wrote:
> Use to_delayed_work() instead of open-coding it.
>
> Signed-off-by: Geliang Tang <geliangtang@xxxxxxx>

Thanks, applied for next.

Kind regards
Uffe

> ---
> drivers/mmc/host/usdhi6rol0.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/mmc/host/usdhi6rol0.c b/drivers/mmc/host/usdhi6rol0.c
> index b47122d..b2752fe 100644
> --- a/drivers/mmc/host/usdhi6rol0.c
> +++ b/drivers/mmc/host/usdhi6rol0.c
> @@ -1630,7 +1630,7 @@ static irqreturn_t usdhi6_cd(int irq, void *dev_id)
> */
> static void usdhi6_timeout_work(struct work_struct *work)
> {
> - struct delayed_work *d = container_of(work, struct delayed_work, work);
> + struct delayed_work *d = to_delayed_work(work);
> struct usdhi6_host *host = container_of(d, struct usdhi6_host, timeout_work);
> struct mmc_request *mrq = host->mrq;
> struct mmc_data *data = mrq ? mrq->data : NULL;
> --
> 2.5.0
>
>