Re: [PATCH 4/7] mmc: sh_mmcif: use to_delayed_work

From: Ulf Hansson
Date: Wed Jan 27 2016 - 09:15:22 EST


On 1 January 2016 at 15:59, Geliang Tang <geliangtang@xxxxxxx> wrote:
> Use to_delayed_work() instead of open-coding it.
>
> Signed-off-by: Geliang Tang <geliangtang@xxxxxxx>

Thanks, applied for next.

Kind regards
Uffe

> ---
> drivers/mmc/host/sh_mmcif.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/mmc/host/sh_mmcif.c b/drivers/mmc/host/sh_mmcif.c
> index 1ca8a13..e0c076a 100644
> --- a/drivers/mmc/host/sh_mmcif.c
> +++ b/drivers/mmc/host/sh_mmcif.c
> @@ -1395,7 +1395,7 @@ static irqreturn_t sh_mmcif_intr(int irq, void *dev_id)
>
> static void sh_mmcif_timeout_work(struct work_struct *work)
> {
> - struct delayed_work *d = container_of(work, struct delayed_work, work);
> + struct delayed_work *d = to_delayed_work(work);
> struct sh_mmcif_host *host = container_of(d, struct sh_mmcif_host, timeout_work);
> struct mmc_request *mrq = host->mrq;
> struct device *dev = sh_mmcif_host_to_dev(host);
> --
> 2.5.0
>
>