Re: [PATCH 3/4] tpm: seal/unseal for TPM 2.0

From: Jason Gunthorpe
Date: Tue Oct 13 2015 - 13:35:13 EST


On Fri, Oct 02, 2015 at 11:38:17AM +0300, Jarkko Sakkinen wrote:
> Added tpm_trusted_seal() and tpm_trusted_unseal() API for sealing
> trusted keys.
>
> This patch implements basic sealing and unsealing functionality for
> TPM 2.0:

We really need to stop using chip id's as a handle - the caller should
be using a pointer, it is just a horrible API, and the TPM_ANY_NUM
business is awful too.. TPM's are stateful devices!

Is it feasible to introduce new APIs with a saner scheme?

The api layering also seems really weird to me. At a minimum the
tpm_seal_trusted should be called within key_seal, but really, should
key_seal be migrated into the TPM core? I'm not sure it makes alot of
sense to have a tpm_seal_trusted which uses the high level key structs
when other tpm functions are all low level RPC wrappers...

Jason
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/