Re: [PATCHv3 0/8] zram stats rework and code cleanup

From: Minchan Kim
Date: Fri Jan 17 2014 - 02:08:45 EST


On Thu, Jan 16, 2014 at 04:12:08PM +0300, Sergey Senozhatsky wrote:
> This patchset includes zram stats clean up and enhancements.
>
> Sergey Senozhatsky (8):
> zram: drop `init_done' struct zram member
> zram: do not pass rw argument to __zram_make_request()
> zram: remove good and bad compress stats
> zram: use atomic64_t for all zram stats
> zram: remove zram stats code duplication
> zram: report failed read and write stats
> zram: drop not used table `count' member
> zram: move zram size warning to documentation
>
> Documentation/blockdev/zram.txt | 5 ++
> drivers/block/zram/zram_drv.c | 175 +++++++++++++---------------------------
> drivers/block/zram/zram_drv.h | 10 +--
> 3 files changed, 64 insertions(+), 126 deletions(-)

Great clean up.

Sergey, Thanks!
I am looking forward to your next step!

--
Kind regards,
Minchan Kim
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/