Re: [PATCHv3 4/8] zram: use atomic64_t for all zram stats

From: Minchan Kim
Date: Fri Jan 17 2014 - 01:53:23 EST

On Thu, Jan 16, 2014 at 04:12:12PM +0300, Sergey Senozhatsky wrote:
> This is a preparation patch for stats code duplication removal.
> 1) use atomic64_t for `pages_zero' and `pages_stored' zram stats.
> 2) `compr_size' and `pages_zero' struct zram_stats members did not
> follow the existing device attr naming scheme: zram_stats.ATTR has
> ATTR_show() function. rename them:
> -- compr_size -> compr_data_size
> -- pages_zero -> zero_pages
> Minchan Kim's note:
> If we really have trouble with atomic stat operation, we could
> change it with percpu_counter so that it could solve atomic overhead and
> unnecessary memory space by introducing unsigned long instead of 64bit
> atomic_t.
> Signed-off-by: Sergey Senozhatsky <sergey.senozhatsky@xxxxxxxxx>
Acked-by: Minchan Kim <minchan@xxxxxxxxxx>

Kind regards,
Minchan Kim
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at