Re: [PATCH -tip 1/2] [BUGFIX] kprobes/x86: Prohibit probing on debug_stack_*

From: Masami Hiramatsu
Date: Thu Oct 31 2013 - 22:03:41 EST

(2013/10/31 17:22), Ingo Molnar wrote:
> * Masami Hiramatsu <> wrote:
>> -int is_debug_stack(unsigned long addr)
>> +int __kprobes is_debug_stack(unsigned long addr)
> _Please_ add a __noprobes method, for new annotations.

Ah, OK. I'll send new series.

> Naming it '__kprobes' is actively confusing, as it suggests that the
> function is somehow positively involved with kprobes support.
> Instead it should the noinline/notrace pattern.
> I complained about this before and not much happened on this front.
> We might not want to convert the whole kernel straight away, but for
> _new_ annotations there's no excuse not to name them properly. Lets
> phase out __kprobes, and use __noprobe from now on, okay?

I see it. :)

Thank you,

IT Management Research Dept. Linux Technology Center
Hitachi, Ltd., Yokohama Research Laboratory

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at