ddccontrol doesn't work on the new kernel

From: dbz
Date: Fri Oct 25 2013 - 09:51:29 EST

Hi, guys and girls!

I have a strange trouble with ddccontrol that I cannot identify and solve
for about a month, so I hope you'll be able to help me.

So, I'm using LMDE system (http://linuxmint.com/start/debian/). Initially
the kernel was 3.2.32, and ddccontrol worked perfectly with my Philips
232E2SB. I was able to change monitor brightness through ddccontrol
commands and I was really happy :)

Then I upgraded my system to Update Pack 7, and the new kernel became of
version 3.10.5. On new kernel ddccontrol doesn't work anymore, but it still
works on the old one (so this isn't software issue).

I have checked kernel configs - for the old kernel and for the new one.
Both configs are identical at i2c sections. I've tried to use old (3.2.32's
one) config with the new kernel, but there was no success.

To be absolutely sure that the problem isn't in the this specific kernel
version (3.10.5), I've downloaded the latest one (3.11.3) from kernel.org and
tried to use old config on this new kernel, but the issue is still

It would be great if you can give me right direction on this issue, 'cause
I don't know what to do now... I really need new kernel and ability to use

P.S. Additional info:
The output of 'i2cdetect -l' on the old kernel (3.2.32):
The same on the new one (3.10.5): http://pastebin.com/YCTmX90m

The output of 'ddccontrol -p' on the old kernel (3.2.32):
The same on the new one (3.10.5): http://pastebin.com/vZ4bALmt

And dmesg outputs for both 3.2.32 and 3.10.5 kernels:
- 3.2.32: http://pastebin.com/7ijujvkA
- 3.10.5: http://pastebin.com/t1wdKrAd

I really need someone's help with ddccontrol. It would be great if you or
someone else who do you know can help me :)

Thank you in advance!èº{.nÇ+‰·Ÿ®‰­†+%ŠËlzwm…ébëæìr¸›zX§»®w¥Š{ayºÊÚë,j­¢f£¢·hš‹àz¹®w¥¢¸ ¢·¦j:+v‰¨ŠwèjØm¶Ÿÿ¾«‘êçzZ+ƒùšŽŠÝj"ú!¶iO•æ¬z·švØ^¶m§ÿðà nÆàþY&—