Re: [PATCH 08/11] inode: convert per-sb inode list to a list_lru

From: Dave Chinner
Date: Thu Aug 01 2013 - 21:06:26 EST

On Thu, Aug 01, 2013 at 01:19:50AM -0700, Christoph Hellwig wrote:
> At this point the list_lru name really becomes confusing. Given that
> it's not really LRU specific maybe just rename it to pernode_list
> or similar?

Well, such things were suggested when the list_lru was first
proposed. Indeed, it even lived in lib/ because I saw it as widely
useful. But akpm didn't like it because of the "structure with
internal locking" architecture and thought it was too purpose
specific for generic use and so it got moved uot of lib/ into mm/
and here we are.

I don't care for how it's named, located or used - I just want to be
able to use the infrastructure it provides. As such renaming and
relocating it is not something I'm about to do in this specific


Dave Chinner
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at