Re: [PATCH v8, part3 12/14] mm: correctly update zone->mamaged_pages

From: Liu Jiang
Date: Tue May 28 2013 - 10:21:12 EST


Hi Sergei,
Thanks for review!

On 05/27/2013 09:57 PM, Sergei Shtylyov wrote:
> On 26-05-2013 17:38, Jiang Liu wrote:
>
> Typo in the subject: s/mamaged_pages/managed_pages/.
Will fix it in next version.

>
>> Enhance adjust_managed_page_count() to adjust totalhigh_pages for
>> highmem pages. And change code which directly adjusts totalram_pages
>> to use adjust_managed_page_count() because it adjusts totalram_pages,
>> totalhigh_pages and zone->managed_pages altogether in a safe way.
>
>> Remove inc_totalhigh_pages() and dec_totalhigh_pages() from xen/balloon
>> driver bacause adjust_managed_page_count() has already adjusted
>> totalhigh_pages.
>
>> This patch also fixes two bugs:
>> 1) enhances virtio_balloon driver to adjust totalhigh_pages when
>> reserve/unreserve pages.
>> 2) enhance memory_hotplug.c to adjust totalhigh_pages when hot-removing
>> memory.
>
>> We still need to deal with modifications of totalram_pages in file
>> arch/powerpc/platforms/pseries/cmm.c, but need help from PPC experts.
>
>> Signed-off-by: Jiang Liu <jiang.liu@xxxxxxxxxx>
>> Cc: Chris Metcalf <cmetcalf@xxxxxxxxxx>
>> Cc: Rusty Russell <rusty@xxxxxxxxxxxxxxx>
>> Cc: "Michael S. Tsirkin" <mst@xxxxxxxxxx>
>> Cc: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
>> Cc: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
>> Cc: Wen Congyang <wency@xxxxxxxxxxxxxx>
>> Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>
>> Cc: Tang Chen <tangchen@xxxxxxxxxxxxxx>
>> Cc: Yasuaki Ishimatsu <isimatu.yasuaki@xxxxxxxxxxxxxx>
>> Cc: Mel Gorman <mgorman@xxxxxxx>
>> Cc: Minchan Kim <minchan@xxxxxxxxxx>
>> Cc: linux-kernel@xxxxxxxxxxxxxxx
>> Cc: virtualization@xxxxxxxxxxxxxxxxxxxxxxxxxx
>> Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
>> Cc: linux-mm@xxxxxxxxx
>> ---
>> drivers/virtio/virtio_balloon.c | 8 +++++---
>> drivers/xen/balloon.c | 23 +++++------------------
>> mm/hugetlb.c | 2 +-
>> mm/memory_hotplug.c | 16 +++-------------
>> mm/page_alloc.c | 10 +++++-----
>> 5 files changed, 19 insertions(+), 40 deletions(-)
>
>> diff --git a/drivers/virtio/virtio_balloon.c
>> b/drivers/virtio/virtio_balloon.c
>> index bd3ae32..6649968 100644
>> --- a/drivers/virtio/virtio_balloon.c
>> +++ b/drivers/virtio/virtio_balloon.c
> [...]
>> @@ -160,11 +160,13 @@ static void fill_balloon(struct virtio_balloon
>> *vb, size_t num)
>> static void release_pages_by_pfn(const u32 pfns[], unsigned int num)
>> {
>> unsigned int i;
>> + struct page *page;
>
> Why not declare it right in the *for* loop? You could use intializer
> then...
Good suggestion, will change it in next version.

>
>>
>> /* Find pfns pointing at start of each page, get pages and free
>> them. */
>> for (i = 0; i < num; i += VIRTIO_BALLOON_PAGES_PER_PAGE) {
>> - balloon_page_free(balloon_pfn_to_page(pfns[i]));
>> - totalram_pages++;
>> + page = balloon_pfn_to_page(pfns[i]);
>> + balloon_page_free(page);
>> + adjust_managed_page_count(page, 1);
>> }
>> }
>>
> [...]
>
> WBR, Sergei
>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/