Re: [PATCH 02/14] misc/ep93xx_pwm: use {read,write}* instead of __raw_* versions for io

From: Arnd Bergmann
Date: Mon May 27 2013 - 13:07:24 EST


On Monday 27 May 2013, H Hartley Sweeten wrote:
> On Monday, May 27, 2013 8:18 AM, Arnd Bergmann wrote:
> > On Saturday 25 May 2013, H Hartley Sweeten wrote:
> >> @@ -42,13 +42,13 @@ struct ep93xx_pwm {
> >> static inline void ep93xx_pwm_writel(struct ep93xx_pwm *pwm,
> >> unsigned int val, unsigned int off)
> >> {
> >> - __raw_writel(val, pwm->mmio_base + off);
> >> + writel(val, pwm->mmio_base + off);
> >> }
> >
> > Just an idea: since you are adding the writel in a lot of places in subsequent
> > patches, you could rename 'mmio_base' to the shorter 'base' first, which would
> > make the resulting code actually smaller.
>
> Hmm.. It would make the source file a bit smaller but the compiled size would
> be the same.

Right.

> But, I'll probably rename the variable when I convert this driver to the PWM
> framework.

Ok.

Arnd

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/