Re: [PATCH v3 5/5] gpio: Make of_count_named_gpios() use new of_count_phandle_with_args()

From: Andreas Larsson
Date: Wed Feb 13 2013 - 05:00:24 EST

On 2013-02-13 00:06, Grant Likely wrote:
This patch replaces the horribly coded of_count_named_gpios() with a
call to of_count_phandle_with_args() which is far more efficient. This
also changes the return value of of_gpio_count() & of_gpio_named_count()
from 'unsigned int' to 'int' so that it can return an error code. All
the users of that function are fixed up to correctly handle a negative
return value.

v2: Split GPIO portion into a separate patch

Signed-off-by: Grant Likely <grant.likely@xxxxxxxxxxxx>
Cc: Linus Walleij <linus.walleij@xxxxxxxxxx>
Cc: Rob Herring <rob.herring@xxxxxxxxxxx>
Cc: Andreas Larsson <andreas@xxxxxxxxxxx>

For gpiolib-of.c, of_gpio.h and spi.c:
Tested-by: Andreas Larsson <andreas@xxxxxxxxxxx>

Andreas Larsson

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at