Re: [char-misc-next 01/12 v3] mei: Rename mei_device to mei_host
From: Samuel Ortiz
Date: Tue Feb 12 2013 - 16:29:41 EST
On Tue, Feb 12, 2013 at 09:17:21PM +0000, Winkler, Tomas wrote:
> > In preparation for the MEI bus code merge, we rename the mei_device
> > structure to mei_host.
> > struct mei_device will be used for devices on the MEI bus in order to follow
> > exisiting driver model implementations practices.
> I'd like to NACK this name, we use 'host' for the host part of the MEI protocol,
> You can use the mei_controller, mei_adapter, and I'm not sure what else can come into mind.
mei_controller sounds good to me.
> I prefer not to break the HW spec language. I prefer to leave it mei_device as after all it's a device on pci bus it's not a pure host controller.
> And call what is on the mei bus mei_cl_dev or mei_app_dev . From the HW perspective it actually
> talks to a client/application residing inside MEI device, it is not always a physical device like NFC.
The bus is not physical neither. It's really items that we add to this bus,
watchdog could be the next candidate for example.
> Please let's find something that makes both hw and Linux happy
I still believe it makes sense to use mei_device for what we add to the MEI
bus. I'd be fine with mei_bus_device as well, but that would somehow look
a bit awkward. Greg, Arnd, any preference ?
>From the MEI core code readers perspective, this will mostly be transparent
as only the technology specific parts of the MEI driver (e.g. nfc.c) will use
that mei_device structure.
Intel Open Source Technology Centre
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/