Re: [PATCH 0/3] mm: rename confusing function names

From: Robin Holt
Date: Fri Feb 08 2013 - 08:35:28 EST


> > static unsigned int nr_free_zone_pages(int offset)
> > {
> > ...
> > unsigned int sum = 0;
> > ...
> > return sum;
> > }
> >
> > How long will it be until these things start exploding from
> > sums-of-zones which exceed 16TB?
> >
>
> You mean overflow? Hmm.. it might happens. Change the sum to
> unsigned long is ok?

We are in the process right now of building a 32TB machine. Let me make
a note about this right away. Thankfully, the memory will be spread
over 256 zones so it should not impact us right away.

Thanks,
Robin
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/