Re: [resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

From: Andy Shevchenko
Date: Wed Jan 09 2013 - 09:57:51 EST


On Wed, Jan 9, 2013 at 4:19 PM, Viresh Kumar <viresh.kumar@xxxxxxxxxx> wrote:
> n 9 January 2013 19:20, Vinod Koul <vinod.koul@xxxxxxxxx> wrote:
>>> +static inline bool is_slave_xfer(enum dma_transfer_direction direction)
>>> +{
>>> + return (direction == DMA_MEM_TO_DEV) || (direction == DMA_DEV_TO_MEM);
>>> +}
>> After reading the subsequent patch I understand what is intent here. Perhaps
>> is_slave_dirn() would have been a beter one...
>
> dirn isn't readable, it took me some time to understand the intent...
> Either have xfer or direction :)

Agree with Viresh. I might rename it to is_slave_direction if you want to.

--
With Best Regards,
Andy Shevchenko
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/