Re: [PATCH] allow gpiolib to be a module

From: Jan Beulich
Date: Thu Sep 13 2012 - 02:59:17 EST

>>> On 12.09.12 at 19:41, Randy Dunlap <rdunlap@xxxxxxxxxxxx> wrote:
> On 09/12/2012 12:43 AM, Jan Beulich wrote:
>>>>> On 11.09.12 at 19:38, Linus Walleij <linus.walleij@xxxxxxxxxx> wrote:
>>> On Mon, Sep 10, 2012 at 2:16 PM, Jan Beulich <JBeulich@xxxxxxxx> wrote:
>>>> + return gpiolib_sysfs_init() ?: gpiolib_debugfs_init();
>>> I can't parse this, sorry the gpio subsystem maintainer is too bad coder.
>>> What about something more readable?
>>> int ret;
>>> ret = gpiolib_sysfs_init();
>>> if (ret)
>>> return ret;
>>> return gpiolib_debugfs_init();
>>> I know it doesn't look as cool but it's easier for me to understand.
>> Okay, since you're the second one to complain despite there
>> being other uses of the construct in the same source file, I'll
>> replace it, ...
> Does C just use the value generated from the left side of a ?:
> expression for the middle (empty) expression or does it call the
> function again (which would usually be bad)?

It's the purpose of omitting the middle expression to avoid the
second evaluation of that expression (and obviously the compiler
can't generally do this on its own when seeing the same
expression used twice).


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at