Re: [PATCH] [Trivial] qib: fix an incorrect message

From: Betty Dall
Date: Thu Jul 19 2012 - 14:56:09 EST

Hi Joe,

Thanks for the comment Joe. It looks like Roland already accepted the
trivial change.

On Thu, 2012-07-19 at 11:03 -0700, Joe Perches wrote:
> On Thu, 2012-07-19 at 13:34 -0600, Betty Dall wrote:
> > There is a cut and paste typo in the function qib_pci_slot_reset() where
> > it prints that the "link_reset" function is called rather than the
> > "slot_reset" function. This makes the message misleading.
> Hi Betty.
> > diff --git a/drivers/infiniband/hw/qib/qib_pcie.c b/drivers/infiniband/hw/qib/qib_pcie.c
> []
> > @@ -725,7 +725,7 @@ qib_pci_mmio_enabled(struct pci_dev *pdev)
> > static pci_ers_result_t
> > qib_pci_slot_reset(struct pci_dev *pdev)
> > {
> > - qib_devinfo(pdev, "QIB link_reset function called, ignored\n");
> > + qib_devinfo(pdev, "QIB slot_reset function called, ignored\n");
> These sorts of typos can be avoided by using "%s: ", __func__
> qib_devinfo(pdev, "QIB %s: called, ignored\n", __func__);

You are right about using __func__. That is what I use typically too. In
this file, none of the qib_devinfo() messages use __func__, so I stuck
with the trivial change for consistency. I could write another patch
that makes use of __func__ for all the appropriate qib_devinfo() calls
(there are 4 of them.) Do you think that is a worthwhile change? BTW, I
did review all the other qib_devinfo() calls to make sure they are using
the correct function names, and they look good.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at