Re: [PATCH] edac.h: Add generic layers for describing a memorylocation

From: Borislav Petkov
Date: Tue Apr 24 2012 - 09:38:59 EST


On Tue, Apr 24, 2012 at 10:22:09AM -0300, Mauro Carvalho Chehab wrote:
> The count of elements of a layer is the size of the layer. The Kernel macro
> that gets the number of elements of an array is called "ARRAY_SIZE", and not
> "ARRAY_N_ELEMS".
>
> layers->size is the dimension of the layer. So, the term "size" fits better.
> For example, according with [1], size means:
> "the spatial dimensions, proportions, magnitude, or bulk of anything:
> the size of a farm; the size of the fish you caught."
>
> so, "size" fits better for a "dimension" measure.
>
> I don't mind renaming it to n_elems, if this makes you happy.

Ok, let's do a simple comparison:

1. Imagine you look at ARRAY_SIZE(), what does it mean? Well, the size
of an array is pretty well defined to be the number of elements in it.
Easy.

2. Now imagine a struct member ->size. Out of context it could mean
anything, the size of something this struct represents, what the hell do
I know...

Now let's put it in context, layer->size: It could mean the size of the
layer in MB, it could mean how thick the layer is in meters, it could
... I can go on with these forever.

So your example with ARRAY_SIZE does not apply here.

If it is a badly explained struct and size is "maximum size" then this
means sh*t. So either leave it "size" but make sure to explain it
thoroughly what exactly size means here or change its name to something
more meaningful.

--
Regards/Gruss,
Boris.

Advanced Micro Devices GmbH
Einsteinring 24, 85609 Dornach
GM: Alberto Bozzo
Reg: Dornach, Landkreis Muenchen
HRB Nr. 43632 WEEE Registernr: 129 19551
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/