Re: [PATCH 08/15] mm: mmzone: MIGRATE_CMA migration type added

From: Michal Nazarewicz
Date: Sun Feb 05 2012 - 09:37:18 EST

+static inline bool migrate_async_suitable(int migratetype)

On Fri, 03 Feb 2012 15:19:54 +0100, Hillf Danton <dhillf@xxxxxxxxx> wrote:
Just nitpick, since the helper is not directly related to what async
means, how about migrate_suitable(int migrate_type) ?

2012/2/3 Michal Nazarewicz <mina86@xxxxxxxxxx>:
I feel current name is better suited since it says that it's OK to scan this
block if it's an asynchronous compaction run.

On Sat, 04 Feb 2012 10:09:02 +0100, Hillf Danton <dhillf@xxxxxxxxx> wrote:
The input is the migrate type of page considered, and the async is only one
of the modes that compaction should be carried out. Plus the helper is
also used in other cases where async is entirely not concerned.

That said, the naming is not clear, if not misleading.

In the first version the function was called is_migrate_cma_or_movable() which
described what the function checked. Mel did not like it though, hence the
change to migrate_async_suitable(). Honestly, I'm not sure what would be the
best name for function.

Best regards, _ _
.o. | Liege of Serenely Enlightened Majesty of o' \,=./ `o
..o | Computer Science, MichaÅ âmina86â Nazarewicz (o o)
ooo +----<email/xmpp: mpn@xxxxxxxxxx>--------------ooO--(_)--Ooo--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at