Re: RFC: Boiler plate functions for ida / idr allocation?

From: Jonathan Cameron
Date: Thu Jul 21 2011 - 04:29:43 EST


On 07/21/11 09:19, Tejun Heo wrote:
> On Thu, Jul 21, 2011 at 05:07:36PM +0930, Rusty Russell wrote:
>> From: Rusty Russell <rusty@xxxxxxxxxxxxxxx>
>> Subject: ida: Simplified functions for id allocation.
>>
>> The current hyper-optimized functions are overkill if you simply want
>> to allocate an id for a device. Create versions which use an internal
>> lock.
>>
>> Thanks to Tejun for feedback. Feel free to delete the #ifdef TEST
>> code.
>>
>> Signed-off-by: Rusty Russell <rusty@xxxxxxxxxxxxxxx>
> ...
>> static struct kmem_cache *idr_layer_cache;
>> +static DEFINE_SPINLOCK(simple_ida);
>
> I think the name is a bit confusing. Maybe simple_ida_lock is better?
> Other than that,
>
> Acked-by: Tejun Heo <tj@xxxxxxxxxx>
>
> I guess this is best routed through -mm?
>
> Thanks.
>
Thanks Rusty. Just what I was looking for. I'll push out some patches using
this once it's picked up.

Acked-by: Jonathan Cameron <jic23@xxxxxxxxx>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/