Re: [PATCH 11/18] fs: Introduce per-bucket inode hash locks

From: Al Viro
Date: Fri Oct 08 2010 - 05:49:22 EST


On Fri, Oct 08, 2010 at 04:21:25PM +1100, Dave Chinner wrote:
> - if (hlist_unhashed(&inode->i_hash))
> + if (hlist_bl_unhashed(&inode->i_hash))

That, OTOH, begs for (inlined) helper with more readable name.

> HFS_I(inode)->rsrc_inode = dir;
> HFS_I(dir)->rsrc_inode = inode;
> igrab(dir);
> - hlist_add_head(&inode->i_hash, &HFS_SB(dir->i_sb)->rsrc_inodes);
> + hlist_bl_add_head(&inode->i_hash, &HFS_SB(dir->i_sb)->rsrc_inodes);
> mark_inode_dirty(inode);

Lovely. What protects that list? Same question for hfsplus...
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/