Re: [RFC 3/6] x86, NMI, Rename memory parity error to PCI SERRerror

From: Huang Ying
Date: Sun Sep 12 2010 - 22:02:25 EST


On Mon, 2010-09-13 at 09:02 +0800, Robert Richter wrote:
> On 09.09.10 22:51:02, Huang Ying wrote:
> > memory parity error is only valid for IBM PC-AT, newer machine use 7
> > bit (0x80) of 0x61 port for PCI SERR. While memory error is usually
> > reported via MCE. So corresponding function name and kernel log string
> > is changed.
> >
> > Signed-off-by: Huang Ying <ying.huang@xxxxxxxxx>
> > ---
> > arch/x86/include/asm/mach_traps.h | 6 +++---
> > arch/x86/kernel/traps.c | 24 ++++++------------------
> > 2 files changed, 9 insertions(+), 21 deletions(-)
> >
> > --- a/arch/x86/include/asm/mach_traps.h
> > +++ b/arch/x86/include/asm/mach_traps.h
> > @@ -9,11 +9,11 @@
> >
> > #define NMI_REASON_PORT 0x61
> >
> > -#define NMI_REASON_MEMPAR 0x80
> > +#define NMI_REASON_SERR 0x80
> > #define NMI_REASON_IOCHK 0x40
> > -#define NMI_REASON_MASK (NMI_REASON_MEMPAR | NMI_REASON_IOCHK)
> > +#define NMI_REASON_MASK (NMI_REASON_SERR | NMI_REASON_IOCHK)
> >
> > -#define NMI_REASON_CLEAR_MEMPAR 0x04
> > +#define NMI_REASON_CLEAR_SERR 0x04
> > #define NMI_REASON_CLEAR_IOCHK 0x08
> > #define NMI_REASON_CLEAR_MASK 0x0f
>
> Haven't you introduced *_MEMPAR with patch 1/6?

Yes. And I suggest to rename it to *_SERR in this patch to reflect the
contemporary hardware better. I think they are two steps: naming the
magic number and changing the name of constant and function.

Best Regards,
Huang Ying


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/