Re: [PATCH 2/2] Driver core: reduce duplicated code

From: Uwe Kleine-König
Date: Tue Jun 15 2010 - 05:05:14 EST


On Tue, Jun 15, 2010 at 10:47:56AM +0200, Uwe Kleine-König wrote:
> This makes the two similar functions platform_device_register_simple
> and platform_device_register_data one line inline functions using a new
> generic function platform_device_register_resndata.
I forgot to add some comments to this mail, ... sorry.

- I'm not completely happy with the name of the new function. If
someone has a better name please tell me.
- can platform_device_register_resndata be moved to __init_or_module?
- I moved the kernel docs to the header but didn't test if they are
picked up when generating docs. Even if not, there is no better
place, is there?

Best regards

Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | |
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at