Re: [PATCH 06/12] vmscan: simplify shrink_inactive_list()

From: Rik van Riel
Date: Mon Jun 14 2010 - 14:07:52 EST


On 06/14/2010 07:17 AM, Mel Gorman wrote:
From: KOSAKI Motohiro<kosaki.motohiro@xxxxxxxxxxxxxx>

Now, max_scan of shrink_inactive_list() is always passed less than
SWAP_CLUSTER_MAX. then, we can remove scanning pages loop in it.
This patch also help stack diet.

detail
- remove "while (nr_scanned< max_scan)" loop
- remove nr_freed (now, we use nr_reclaimed directly)
- remove nr_scan (now, we use nr_scanned directly)
- rename max_scan to nr_to_scan
- pass nr_to_scan into isolate_pages() directly instead
using SWAP_CLUSTER_MAX

Signed-off-by: KOSAKI Motohiro<kosaki.motohiro@xxxxxxxxxxxxxx>
Reviewed-by: Johannes Weiner<hannes@xxxxxxxxxxx>

Other than the weird whitespace below,

Reviewed-by: Rik van Riel <riel@xxxxxxxxxx>

+ /*
+ * If we are direct reclaiming for contiguous pages and we do
+ * not reclaim everything in the list, try again and wait
+ * for IO to complete. This will stall high-order allocations
+ * but that should be acceptable to the caller
+ */
+ if (nr_reclaimed< nr_taken&& !current_is_kswapd()&& sc->lumpy_reclaim_mode) {
+ congestion_wait(BLK_RW_ASYNC, HZ/10);

--
All rights reversed
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/