Re: [PATCH 03/28] rename anon_vma_lock to vma_lock_anon_vma

From: Mel Gorman
Date: Wed Jun 09 2010 - 06:59:43 EST

On Mon, Jun 07, 2010 at 01:06:57PM +0200, Peter Zijlstra wrote:
> From: Rik van Riel <riel@xxxxxxxxxx>
> Rename anon_vma_lock to vma_lock_anon_vma. This matches the
> naming style used in page_lock_anon_vma and will come in really
> handy further down in this patch series.
> Signed-off-by: Rik van Riel <riel@xxxxxxxxxx>
> Acked-by: Mel Gorman <mel@xxxxxxxxx>
> Acked-by: KAMEZAWA Hiroyuki <kamezawa.hiroyu@xxxxxxxxxxxxxx>
> Signed-off-by: Peter Zijlstra <a.p.zijlstra@xxxxxxxxx>
> LKML-Reference: <20100526153853.55b72183@xxxxxxxxxxxxxxxxxxxxx>

One rename was missed I think. With this patch applied, I get

mm/mmap.c: In function â??expand_downwardsâ??:
mm/mmap.c:1786: error: implicit declaration of function â??anon_vma_unlockâ??
make[1]: *** [mm/mmap.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make: *** [mm] Error 2

Mel Gorman
Part-time Phd Student Linux Technology Center
University of Limerick IBM Dublin Software Lab
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at