Re: kvm: network problem with Solaris 10u8 guest

From: Michael Tokarev
Date: Wed May 19 2010 - 15:40:10 EST

19.05.2010 21:09, Avi Kivity wrote:
On 05/19/2010 04:46 PM, Harald Dunkel wrote:
I am trying to run Solaris 10u8 as a guest in kvm (kernel Problem: The virtual network devices don't work
with this Solaris version.

e1000 and pcnet work just by chance, as it seems. I can ping
the guest (even though some packets are lost). I cannot use
ssh to login.

rtl8139 and ne2k_pci are not even listed by "ifconfig -a" on
the guest.

Solaris 10u6 worked fine (using the e1000 emulation). Same for
the Linux guests.

Does opensolaris exhibit the the same problems? If so, you can probably
bisect the driver to find the change that broke the device. With that we
can probably deduce if it is the device or driver that is broken, and
what the issue is.

I verified this right after Harald posted his original
bugreport against debian qemu-kvm package (*). No,
opensolaris does NOT shows this bug.

I even tried solaris install image -- sol-10-u8-ga-x86-dvd.iso,
but it works here as far as I can see. I performed only basic
tests however, -- basically because I just don't remember how
to _use_ solaris (it's been about 10 years ago), and can only
do some telnet/ping/ftp.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at