Re: [PATCH] x86, MCE, fix MSR_IA32_MCI_CTL2 CMCI threshold setup

From: H. Peter Anvin
Date: Mon May 17 2010 - 21:38:08 EST


On 05/17/2010 05:51 PM, Huang Ying wrote:
> Hi, Peter,
>
> Thanks for review.
>
> On Tue, 2010-05-18 at 01:59 +0800, H. Peter Anvin wrote:
>> On 05/17/2010 01:08 AM, Huang Ying wrote:
>>> It is reported that CMCI is not raised when number of corrected error
>>> reaches preset threshold. After inspection, it is found that
>>> MSR_IA32_MCI_CTL2 threshold field is not setup properly. This patch
>>> fixed it.
>>>
>>>
>>> Changelog:
>>>
>>> v2:
>>>
>>> - Rename CMCI_EN to MCI_CTL2_CMCI_EN and CMCI_THRESHOLD_MASK to
>>> MCI_CTL2_CMCI_THRESHOLD_MASK to make naming consistent.
>>>
>>
>> This looks like a mix of a renaming patch and new functionality. Please
>> submit the renaming as a one patch and then the new functionality as a
>> second patch on top, otherwise it gets hard to see what is actually
>> going on.
>>
>> If I'm not mistaken, there are at least two functionality changes:
>>
>> +#define MCI_CTL2_CMCI_THRESHOLD_MASK 0x7fffULL
>> -#define CMCI_THRESHOLD_MASK 0xffffULL
>>
>> ... change of mask, and:
>>
>> - val |= CMCI_EN | CMCI_THRESHOLD;
>> + val &= ~MCI_CTL2_CMCI_THRESHOLD_MASK;
>> + val |= MCI_CTL2_CMCI_EN | CMCI_THRESHOLD;
>>
>> bit being cleared which wasn't before.
>
> This means we need 3 patches?
>

No, two patches is fine -- one for the rename (no binary changes) and
one for the functionality changes.

-hpa

--
H. Peter Anvin, Intel Open Source Technology Center
I work for Intel. I don't speak on their behalf.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/