Re: [PATCH -v9 00/31] use lmb with x86

From: Yinghai Lu
Date: Mon Mar 29 2010 - 16:41:14 EST


On 03/29/2010 09:52 AM, Yinghai Lu wrote:
> On 03/29/2010 05:22 AM, Michael Ellerman wrote:
>> On Sun, 2010-03-28 at 19:42 -0700, Yinghai Lu wrote:
>>> the new lmb could be used to early_res in x86.
>>>
>>> Suggested by: David, Ben, and Thomas
>>>
>>> First three patches should go into 2.6.34
>>>
>>> -v6: change sequence as requested by Thomas
>>> -v7: seperate them to more patches
>>> -v8: add boundary checking to make sure not free partial page.
>>> -v9: use lmb_debug to control print out of reserve_lmb.
>>> add e820 clean up, and e820 become __initdata
>>
>> Bike shedding perhaps, but can you maintain the naming convention, ie.
>> lmb_xxx() rather than xxx_lmb(). Neither is necessarily better, but all
>> the existing functions use the lmb_xxx() style.
>>
>
> so you want
>
> find_lmb_area ==> lmb_find_area
> reserve_lmb ==> lmb_reserve
> free_lmb ==> lmb_free
>
> first one is ok,
>
> but next two we already have lmb_reserved and lmb_free without checking and increasing the size of region array.
>
> should i use
> lmb_reserve_with_check?
>

I change

find_lmb_area ==> lmb_find_area
reserve_lmb ==> lmb_reserve_area
free_lmb ==> lmb_free_area

does that look ok to you?

Thanks

Yinghai
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/