Re: [PATCH 1/7] sched: Use for_each_bit

From: Andrew Morton
Date: Sun Jan 31 2010 - 22:00:34 EST


On Mon, 1 Feb 2010 11:54:14 +0900 Akinobu Mita <akinobu.mita@xxxxxxxxx> wrote:

> 2010/2/1 Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>:
> > On Sun, 31 Jan 2010 14:06:10 +0200 Alexey Dobriyan <adobriyan@xxxxxxxxx> wrote:
> >
> >> On Sun, Jan 31, 2010 at 1:53 PM, Akinobu Mita <akinobu.mita@xxxxxxxxx> wrote:
> >> > __#define for_each_cpupri_active(array, idx) __ __ __ __ __ __ __ __ __ __\
> >> > - __for (idx = find_first_bit(array, CPUPRI_NR_PRIORITIES); __ __ \
> >> > - __ __ __ idx < CPUPRI_NR_PRIORITIES; __ __ __ __ __ __ __ __ __ __ __ __ __ __\
> >> > - __ __ __ idx = find_next_bit(array, CPUPRI_NR_PRIORITIES, idx+1))
> >> > + __ __ __ for_each_bit(idx, array, CPUPRI_NR_PRIORITIES)
> >>
> >> It should be called for_each_set_bit().
> >
> > Agree.
>
> (I'm resending because I failed to reply all)
>
> You mean for_each_bit() should be renamed to for_each_set_bit() ?

Yes.

> I'm not sure. But if so, find_first_bit() also should be renamed to
> find_first_set_bit() and so on?

Yes, it should have been. It's a bit late to correct that mistake, but
it's not too late to fix for_each_bit().
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/