Re: New ark3116 driver - testers needed

From: Bart Hartgers
Date: Mon Aug 31 2009 - 02:51:21 EST

2009/8/29 Ondrej Zary <linux@xxxxxxxxxxxxxxxxxxxx>:
> On Sunday 23 August 2009 14:46:16 Bart Hartgers wrote:
>> Hi All,
>> I managed to write an improved ark3116 driver after I figured out that
>> it is just an 16450 UART with some USB glue logic.
>> Compared to the old ark3116 driver it offers the following improvements:
>> - cts/rts handshake support
>> - break signalling
>> - line error detection
>> Since it is a big step from the previous driver, it made little sense
>> to modify that one, so I created new driver, named ark316new. Also
>> this means that both could coexist if the new one doesn't work for
>> someone.
>> I have no datasheet, so the driver is entirely based on reverse
>> engineering, and some testing by others would be a good idea.
>> I also tried to include the IrDA fixes for the old ark3116.c driver
>> that were posted on this list recently, but I could not test if
>> these work, since I don't have the proper hardware.
>> Because of this, I would appreciate reports of both success and
>> failure in using this driver.
> Tested the driver today with that Gembird UIR-22.
> It did not compile neither in nor in 2.6.31-rc8 with the following
> error:
> ark3116new.c:790: error: unknown field shutdown specified in initializer
> ark3116new/ark3116new.c:790: warning: initialization from incompatible pointer
> type
> Commenting that line produced a module that worked:
> usb 1-1: new full speed USB device using uhci_hcd and address 2
> usb 1-1: configuration #0 chosen from 1 choice
> usb 1-1: config 0 descriptor??
> usbcore: registered new interface driver usbserial
> usbserial: USB Serial Driver core
> USB Serial support registered for ARK3116 RS232/IrDA
> ark3116new 1-1:0.0: ARK3116 RS232/IrDA converter detected
> usb 1-1: ark3116new using IrDA mode
> usb 1-1: ARK3116 RS232/IrDA converter now attached to ttyUSB0
> usbcore: registered new interface driver ark3116new
> ark3116new:v0.1:USB ARK3116 serial/IrDA driver
> usb 1-1: ark3116new don't know how to do software flow control
> NET: Registered protocol family 23
> Ran "irattach /dev/ttyUSB0 -s" and then "obexftp -i -l" to list files on Nokia
> 6230i. It worked fine and file transfer too. So the IrDA mode works.
> When I unplugged the device, irattach remained running and some error message
> was written to console every few seconds (sorry, I haven't recorded it).
> Killing irattach then resulted in oops. But this might be expected as the
> shutdown function was commented out.
Hi Ondrej,

Thanks for testing this!

I later discovered that there is a change with respect to
shutdown-functionality between 2.6.28 (on which I made the driver) and
2.6.31. I have to update the driver to 2.6.current anyway.

> I think that this driver should replace current ark3116 driver. Having two
> drivers for the same hardware is a bad thing.

I agree. However, given the experimental nature of the driver, I would
prefer some more testing. Then again, the original driver is lacks
some features, and making ark3116new default would increase its
exposure ;-).


> --
> Ondrej Zary

Bart Hartgers - New e-mail: bart.hartgers@xxxxxxxxx
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at