Re: [PATCH 1/4] compcache: xvmalloc memory allocator

From: Nitin Gupta
Date: Mon Aug 24 2009 - 14:12:13 EST

On 08/24/2009 11:38 PM, Pekka Enberg wrote:
Hi Nitin,

On Mon, Aug 24, 2009 at 8:52 PM, Nitin Gupta<ngupta@xxxxxxxxxx> wrote:
I am okay with renaming it to rzmalloc and compiling it with ramzswap
instead of as separate module.

Is the name rzmalloc() too similar to kzalloc() which stands for
zeroing allocator, though? I think I suggested
ramzswap_alloc()/ramzswap_free() in the past to avoid confusion. I'd
rather go with that if we can't come up with a nice generic name that
stands for alloc_part_of_page_including_highmem().

rzs_malloc()/rzs_free() ?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at