Re: sony-ericsson W800 cellular doesn't work as an usb mass storagedevice

From: "Niklas \"Nille\" Åkerström"
Date: Fri Dec 05 2008 - 00:25:31 EST

Robby Workman wrote:
On Thu, 04 Dec 2008 22:10:50 -0600
Robert Hancock <hancockr@xxxxxxx> wrote:

Niklas "Nille" Åkerström wrote:
Please CC any replies; not subscribed to list

I can't mount my sony-ericsson W800 cellular as an usb mass storage device (it doesn't show up as an device).
I run slackware-current (slackware 12.2 rc1)
Using kernel
It doesn't even show up when i run 'fdisk -l'

How ever running slackware 12.1 using kernel works (used
my other box for 12.1 testing)
I also tried the 12.1 kernel in slackware 12.2 rc1 and
then it works.
So it's seems kernel related. (but i'm not experienced enuff to

Kernel config
Kernel config
dmesg when pluging in the device on dmesg when pluging in the device on running 12.1
dmesg when pluging in the device on running current

My computer is an Compaq Presario 2800
Phone Sony Ericsson W800i 0fce:d028
What other information would be useful?

I searched the mailing list and found which seems releated but there
was no answer.
What do you mean doesn't show up as a device? There doesn't seem to
be anything unusual in the kernel log, you should have a /dev/sda1
device available (at least if udev, etc. are doing their job)..


Kay, is this perhaps related to any of the recent serial devices
discussion on udev list? We've got udev-135 in 12.2rc1, but 12.1
shipped udev-118. Even so, report advises that this still works
properly on the 12.1 kernel ( even with udev-135.

I also think it should show up as /dev/sda1 but it doesn't. (there is no /dev/sda1 device)
When i use the same setup (udev-135 etc.) and only downgrades the kernel to
then it shows up as an mountable device and works as it should.
This made me guess that it has something to do with the kernel.
But i'm only guessing.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at